package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#include \"(.*)\"`)
var str = `#include "whatever.h"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}