$re = '/^(?!-0?(\.0+)?$)-?(0|[1-9]\d*)?(\.\d+)?(?<=\d)$/m';
$str = '"Assistance Listings Number","Title","Types of Assistance","Department/Ind. Agency","Sub-Tier","Related Federal Assistance","Last Date Modified","Date Published","Funded","POC Information"
"39.354","Agriculture Risk Coverage Program","D - Direct Payments with Unrestricted Use","GENERAL SERVICES ADMINISTRATION","","10.055","Dec 13, 2023","Dec 13, 2023","false","Brently N Orr
1400 Independence Ave SW Room 4759-S, Washington DC 20250
(202) 720-7641
"
"39.080","test123_05052022","A - Formula Grants","GENERAL SERVICES ADMINISTRATION","","N/A","Dec 13, 2023","Dec 13, 2023","false","test123
Test Street, Georgetown TX 78626
1236547897
"
"39.105","Auto-Title 234","A - Formula Grants (Health Incentive Grants)","GENERAL SERVICES ADMINISTRATION","","N/A","Dec 13, 2023","Dec 13, 2023","false","NAME 2374
UNION_NUMBER8594, Huntsville AL 17222
0000000000
"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);