import Foundation
let pattern = #"\b(?:1\/22|1 and 1\/2|1\/2|2 to 3 to 4|10|1|2 to 3|2|[\w+'-/]+)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"this happened at 10 o'clock and now after 2 to 3 to 4 hours has gone we've decided to meet 1 and 1/2 hours later. Visit us on 1/22 or 2/12/2012"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)