# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(src|href)\s*=\s*\"[^\" ]*\K\h|(?!^)\G[^\" ]*\K\h"
test_str = ("http://massimodifa.com/dev-area/stefano-busonero/perl-project/wp-11-15/dal Gotico/13-02 Frammenti pittori rococo.htm\n\n"
"http://www.frammentiarte.it/dal%20Gotico/Pittori%20lombardi%20opere/32%20Daniele%20Ranzoni%20-%20La%20principessa%20Saint%20L%C3%A9ger.jpg\n\n"
"<div>\n"
"<div class=\"rTable\">\n"
"<div class=\"rTableRow\">\n"
"<div class=\"rTableCell\">\n"
"<p align=\"center\"><span style=\"font-size: small;\"><b>Beato Angelico: Pala di San Marco</b></span> Predella: ottavo scomparto La sepoltura dei santi Cosma e Damiano</p>\n\n"
"<div class=\"rTable\">\n"
"<div class=\"rTableRow\">\n"
"<div class=\"rTableCell\"><img src=\"http://massimodifa.com/dev area/stefano-busonero/perl-project/wp-11-15/wp-content/uploads/2016/02/dal Gotico/Beato Angelico%20opere/20-beato-angelico-pala-di-san-marco.jpg\" alt=\"La sepoltura dei Santi Cosma e Damiano\" width=\"864\" height=\"676\" /></div>\n"
"</div>\n"
"</div>\n"
"<div class=\"rTable\">\n"
"<div class=\"rTableRow\">\n"
"<div class=\"rTableCell\">Predella: ottavo scomparto La sepoltura dei santi Cosma e Damiano, cm. 37 x 45, Museo di San Marco, Firenze.</div>\n"
"</div>\n"
"</div>\n"
"<div class=\"rTable\">\n"
"<div class=\"rTableRow\">\n"
"<div class=\"rTableCell\"><a href=\"http://massimodifa.com/dev-area/stefano-busonero/perl-project/wp-11-15/dal%20Gotico/Beato%20Angelico%20opere/19-decapitazione-s.-cosma-e-s.-damiano\"><span style=\"font-size: small;\">Alla \"Decapitazione dei santi\"</span></a></div>\n"
"<div class=\"rTableCell\"><a href=\"http://massimodifa.com/dev-area/stefano-busonero/perl-project/wp-11-15/dal%20Gotico/Beato%20Angelico%20opere/12-pala-di-san-marco\"><span style=\"font-size: small;\">Ritorna all'elenco raffigurazioni Pala di San Marco</span></a></div>\n"
"<div class=\"rTableCell\"><a href=\"http://massimodifa.com/dev area/stefano-busonero/perl project/wp-11-15/dal%20Gotico/Beato%20Angelico opere/21-guarigione-del-diacono\">Alla \"Guarigione del diacono Giustiniano\"</a></div>\n"
"</div>\n"
"</div>\n"
"<a href=\"http://massimodifa.com/dev-area/stefano-busonero/perl-project/wp-11-15/dal%20Gotico/Beato%20Angelico opere/0-beato-angelico-opere\"><span style=\"font-size: small;\">Ritorna all'elenco opere di Beato Angelico</span></a>\n"
"<p align=\"justify\"><span style=\"font-size: small;\"> </span></p>\n\n"
"<div class=\"rTable\">\n"
"<div class=\"rTableRow\">\n"
"<div class=\"rTableCell\"></div>\n"
"<div class=\"rTableCell\">\n"
"<p class=\"style10\" align=\"justify\">Sull'opera: \"La sepoltura dei santi Cosma e Damiano\" è un dipinto di Beato Angelico, appartenente alla predella della \"Pala di San Marco\", realizzato con tecnica a tempera su tavola nel 1438-40, misura 37 x 45 cm. ed è custodito nel Museo di San Marco a Firenze.</p>\n"
"<p class=\"style10\" align=\"justify\"></p>\n"
"<p class=\"style10\" align=\"justify\">Prima di pervenire al Museo di San Marco l'opera si trovava all'Accademia di Belle Arti di Firenze. La storia narrata in questa composizione è certamente tratta da un episodio della Legenda aurea, dove il dromedario che trasportava le spoglie di san Damiano incominciò improvvisamente a parlare ordinando di seppellire il santo vicino ai fratelli, di cui si stavano contemporaneamente celebrando le esequie. La scena è ambientata in piazza San Marco, con il convento non ancora completamente edificato (mancante del piano superiore, adiacente alla facciata della chiesa. Sia l'appartenenza alla predella della pala in esame, che l'autografia dell'Angelico, sono accettate universalmente con favore dalla critica ufficiale.</p>\n\n"
"</div>\n"
"</div>\n"
"</div>\n"
"<div class=\"rTable\">\n"
"<div class=\"rTableRow\">\n"
"<div class=\"rTableCell\"><a title=\"opere dei grandi a-e\" href=\"http://massimodifa.com/dev-area/stefano-busonero/perl-project/wp-11-15/dal%20Gotico/Beato%20Angelico%20opere/opere-dei-grandi-a-e\"><span style=\"font-family: Arial; font-size: small;\">Opere Pittori A-E</span></a></div>\n"
"<div class=\"rTableCell\"><a title=\"opere dei grandi f-m\" href=\"http://massimodifa.com/dev-area/stefano-busonero/perl-project/wp-11-15/dal%20Gotico/Beato%20Angelico%20opere/opere-dei-grandi-f-m\"><span style=\"font-family: Arial; font-size: small;\">Opere Pittori F-M</span></a></div>\n"
"<div class=\"rTableCell\"><a title=\"opere dei grandi n-r\" href=\"http://massimodifa.com/dev-area/stefano-busonero/perl-project/wp-11-15/dal%20Gotico/Beato%20Angelico%20opere/opere-dei-grandi-n-r\"><span style=\"font-family: Arial; font-size: small;\">Opere Pittori N-R</span></a></div>\n"
"<div class=\"rTableCell\"><a title=\"opere dei grandi s-z\" href=\"http://massimodifa.com/dev-area/stefano-busonero/perl-project/wp-11-15/dal%20Gotico/Beato%20Angelico%20opere/opere-dei-grandi-s-z\"><span style=\"font-family: Arial; font-size: small;\">Opere Pittori S-Z</span></a></div>\n"
"</div>\n"
"</div>\n"
"</div>\n"
"</div>\n"
"</div>\n"
"<!-- Inizio Codice Shinystat --><!-- Fine Codice Shinystat --></div>")
subst = "%20"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.