// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([01]?[0-9]?[0-9]|2([0-4][0-9]|5[0-5]))\.){3}([01]?[0-9]?[0-9]|2([0-4][0-9]|5[0-5]))$").unwrap();
let string = "validates:
192.68.35.35
0.0.0.0
255.0.0.0
192.168.1.0
192.168.0.1
255.255.255.0
1.1.1.1
255.255.255.255
249.249.249.249
200.200.200.200
199.199.199.199
100.100.100.100
99.99.99.99
0.0.0.0
9.9.9.9
10.10.10.10
99.99.99.99
100.100.100.100
109.109.109.109
110.110.110.110
199.199.199.199
200.200.200.200
249.249.249.249
250.250.250.250
255.255.255.255
does not validate:
256.256.256.260
192.168.0.0/24
192.168..1
192.168.1
1
1.
1.1
1.1.
1.1.1
1.1.1.
1.1.1.1.
1.1.1.1.1
.1.1.1
01.01.01.01
09.09.09.09
1.0.0.1.0
010.1.1.1
123456
123123123123
.127.0.0.1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}