# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:2[0-4]\d|25[0-5]|1\d{2}|[1-9]?\d)\.){3}(?:2[0-4]\d|25[0-5]|1\d{2}|[1-9]?\d)$"
test_str = ("validates:\n"
"192.68.35.35\n"
"0.0.0.0\n"
"255.0.0.0\n"
"192.168.1.0\n"
"192.168.0.1\n"
"255.255.255.0\n"
"1.1.1.1\n"
"255.255.255.255\n"
"249.249.249.249\n"
"200.200.200.200\n"
"199.199.199.199\n"
"100.100.100.100\n"
"99.99.99.99\n"
"0.0.0.0\n"
"9.9.9.9\n"
"10.10.10.10\n"
"99.99.99.99\n"
"100.100.100.100\n"
"109.109.109.109\n"
"110.110.110.110\n"
"199.199.199.199\n"
"200.200.200.200\n"
"249.249.249.249\n"
"250.250.250.250\n"
"255.255.255.255\n\n"
"should not validate:\n"
"256.256.256.260\n"
"192.168.0.0/24\n"
"192.168..1\n"
"192.168.1\n"
"1\n"
"1.\n"
"1.1\n"
"1.1.\n"
"1.1.1\n"
"1.1.1.\n"
"1.1.1.1.\n"
"1.1.1.1.1\n"
".1.1.1\n"
"01.01.01.01\n"
"09.09.09.09\n"
"1.0.0.1.0\n"
"010.1.1.1\n"
"123456\n"
"123123123123\n"
".127.0.0.1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.