$re = '/-([^-]*-[^-]*)\.\w+$/';
$str = 'https://www.abcd.efg/try-till-you-succedd.html';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);