package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\D|^)(\d{2}[-/.]\d{2}[-/.]\d{4})(?:\D|$)`)
var str = `Текст... 23-12-2021 год`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}