$re = '/localhost\_access\_log\.\d[^-].*\.txt$/m';
$str = 'localhost_access_log.2019-11-08.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);