re = /^([\w-]+(?:\.[\w-]+)*)@((?:[\w-]+\.)*\w[\w-]{0,66})\.([a-z]{2,6}(?:\.[a-z]{2})?)$/i
str = 'test@email.org'
# Print the match result
str.match(re) do |match|
puts match.to_s
end