# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.{5}[^$]/$0-/gu;t' <<< "asdsadbaskjbdkjsabkdjbskajbdkjabskd"