$re = '/(\d\d)[\.\-\s]*(.*)\.mp3$/';
$str = '01 -Dirty Deeds Done Dirt Cheap.mp3';
$subst = "$1 $2.mp3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;