package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\$*([^$]+)\$*`)
var str = `$123$456$789$cats$foo$asdflkjlkj#098098098233%$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}