$re = '/\[gcountry (allow|deny)="([\s\S]*?)"\]([\s\S]*?)(?=\[\/gcountry\])/i';
$str = '[gcountry allow="XX,YY"] Text Here [/gcountry]
[gcountry deny="AA,BB"] Text Here [/gcountry] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);