$re = '/^[\d\.]+\s+(\S+)/m';
$str = '2.0 HSD-U 664-999-01 c301036 1251-A 5445
ChanBoard0 233-455-00 c303bb6 1521-A 5445
ChanBoard1 321-493-00 c303496 1321-A 5445
6.0 DC-07 888-375-02 0C31F8F1 1330-A 5445
aka: 604-375-00
DC-07 123-456-01 0C6203EF 1150-A 5445
aka: 939-420-00
7.0 DC-07 613-493-00 c303496 1321-A 5445
aka: 466-456-65
DC-07 613-493-00 c303496 1321-A 5545';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);