using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^#[a-zA-Z0-9_-]+(,(\s)*#[a-zA-Z0-9_-]+)*[^,]$";
string input = @"#test,#teto";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}