using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @", ""[^""]*""(?= \})";
string input = @"{
{ SomeTextNoQuotes, ""Some Text's"", ""Some Text"" },
{ SomeTextNoQuotes, ""Some Text's"", ""Some Text"" },
{ SomeTextNoQuotes, ""Some Text's"", ""Some Text"" },
{ SomeTextNoQuotes, ""Some Text's"", ""Some Text"" },
{ SomeTextNoQuotes, ""Some Text's"", ""Some Text"" },
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}