#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<Time>[0-9]+-[0-9]+-[0-9]+ [0-9]+:[0-9]+:[0-9]+\.[0-9]+).*ResetAlarm .*(?<IP>(?<Oct1>25[0-4]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]|[1-9])\.(?<Oct2>25[0-4]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]|[0-9])\.(?<Oct3>25[0-4]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]|[0-9])\.(?<Oct4>25[0-4]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]|[0-9]))"
Local $sString = "2024-02-18 07:09:27.4281 Camera.GetAlarms 10.247.247.13 Number of alarms has been set to : 1 " & @CRLF & _
"2024-02-18 07:09:27.4365 Camera.GetAlarms [0].x = 203.6222992 .y = 25.4306381 .sz = 91 " & @CRLF & _
"2024-02-18 07:09:27.4405 Camera.GetAlarms [1].x = 569.6733795 .y = 670.1589626 .sz = 166 " & @CRLF & _
"2024-02-18 07:09:27.4445 Camera.GetAlarms [2].x = 842.0031681 .y = 514.4369197 .sz = 93 " & @CRLF & _
"2024-02-18 07:09:27.4484 Camera.GetAlarms [3].x = 565.1266743 .y = 607.1142649 .sz = 82 " & @CRLF & _
"2024-02-18 07:09:49.7165 Camera.ResetAlarms ResetAlarm succeeded on 10.247.247.13 " & @CRLF & _
"2024-02-18 07:33:12.7504 Camera.GetAlarms 10.247.247.13 Number of alarms has been set to : 1 " & @CRLF & _
"2024-02-18 07:33:12.7543 Camera.GetAlarms [0].x = 203.8037819 .y = 27.4721389 .sz = 83 " & @CRLF & _
"2024-02-18 07:33:12.7583 Camera.GetAlarms [1].x = 569.6733795 .y = 670.1589626 .sz = 166 " & @CRLF & _
"2024-02-18 07:33:12.7622 Camera.GetAlarms [2].x = 842.0031681 .y = 514.4369197 .sz = 93 " & @CRLF & _
"2024-02-18 07:33:12.7661 Camera.GetAlarms [3].x = 565.1266743 .y = 607.1142649 .sz = 82 " & @CRLF & _
"2024-02-18 07:33:34.7101 Camera.ResetAlarms ResetAlarm succeeded on 10.247.247.13 " & @CRLF & _
"2024-02-18 07:33:50.7853 Camera.GetAlarms 10.247.247.13 Number of alarms has been set to : 1 " & @CRLF & _
"2024-02-18 07:33:50.7892 Camera.GetAlarms [0].x = 203.8489831 .y = 27.9825939 .sz = 90 " & @CRLF & _
"2024-02-18 07:33:50.7930 Camera.GetAlarms [1].x = 569.6733795 .y = 670.1589626 .sz = 166 " & @CRLF & _
"2024-02-18 07:33:50.7967 Camera.GetAlarms [2].x = 842.0031681 .y = 514.4369197 .sz = 93 " & @CRLF & _
"2024-02-18 07:33:50.8005 Camera.GetAlarms [3].x = 565.1266743 .y = 607.1142649 .sz = 82 " & @CRLF & _
"2024-02-18 07:34:12.7327 Camera.ResetAlarms ResetAlarm succeeded on 10.247.247.13 " & @CRLF & _
"2024-02-18 07:51:04.1777 Camera.GetAlarms 10.247.247.11 Number of alarms has been set to : 1 " & @CRLF & _
"2024-02-18 07:51:04.1814 Camera.GetAlarms [0].x = 845.4836155 .y = 596.2374466 .sz = 335 " & @CRLF & _
"2024-02-18 07:51:04.1859 Camera.GetAlarms [1].x = 338.8315346 .y = 328.7195137 .sz = 140 " & @CRLF & _
"2024-02-18 07:51:04.1898 Camera.GetAlarms [2].x = 969.0846238 .y = 568.3184361 .sz = 94 " & @CRLF & _
"2024-02-18 07:51:04.1939 Camera.GetAlarms [3].x = 205.1083847 .y = 219.807579 .sz = 87 " & @CRLF & _
"2024-02-18 07:51:04.7010 Camera.GetAlarms 10.247.247.11 Number of alarms has been set to : 2 " & @CRLF & _
"2024-02-18 07:51:04.7053 Camera.GetAlarms [0].x = 845.4836155 .y = 596.2374466 .sz = 335 " & @CRLF & _
"2024-02-18 07:51:04.7106 Camera.GetAlarms [1].x = 852.6021284 .y = 548.7173648 .sz = 100 " & @CRLF & _
"2024-02-18 07:51:04.7124 Camera.GetAlarms [2].x = 969.0846238 .y = 568.3184361 .sz = 94 " & @CRLF & _
"2024-02-18 07:51:04.7185 Camera.GetAlarms [3].x = 205.1083847 .y = 219.807579 .sz = 87 " & @CRLF & _
"2024-02-18 07:51:24.3105 Camera.ResetAlarms ResetAlarm succeeded on 10.247.247.11 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")