$re = '/(.*\S)\s+(\d+\s*\S*)$/m';
$str = 'Hauptstr. 23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);