re = /https?:\/\/twitter\.com[^,]+(?<=\/\d$)/m
str = 'https://gofundme.com/ydvmve-surgery-for-jax,https://twitter.com/dog_rates/status/890971913173991426/photo/
https://gofundme.com/ydvmve-surgery-for-jax,https://twitter.com/dog_rates/status/890971913173991426/photo/1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end