#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\(\s*(?P<Val>[a-zA-Z]+[0-9]*|[0-9]+|\'.*\'|\[.*\])\s*(ni|in|\*|\/|\+|\-|==|!=|>|>=|<|<=)\s*(\g{Val})\s*\))"
Local $sString = "(a in b)" & @CRLF & _
"" & @CRLF & _
"(a ni b)" & @CRLF & _
"" & @CRLF & _
"(a in [1,2,3])" & @CRLF & _
"" & @CRLF & _
"([1,2,3] == [1,2,3])" & @CRLF & _
"" & @CRLF & _
"(a == 'Ahmad Hajjar')" & @CRLF & _
"" & @CRLF & _
"((a+1)==b)" & @CRLF & _
"" & @CRLF & _
"(1==1)" & @CRLF & _
"" & @CRLF & _
"( a == a)" & @CRLF & _
"(1==2)" & @CRLF & _
"" & @CRLF & _
"(x1!=y)" & @CRLF & _
"" & @CRLF & _
"(xa1*3)" & @CRLF & _
"" & @CRLF & _
"((7*3)==21)" & @CRLF & _
"" & @CRLF & _
"((17*9)!=(a+b))" & @CRLF & _
"" & @CRLF & _
"((( a + b )*(c-d))==(5/2))" & @CRLF & _
"" & @CRLF & _
"( a+b)" & @CRLF & _
"" & @CRLF & _
"( a - b)" & @CRLF & _
"" & @CRLF & _
"( a/b )" & @CRLF & _
"" & @CRLF & _
"( a * b )" & @CRLF & _
"" & @CRLF & _
"(ahmad>feras)" & @CRLF & _
"" & @CRLF & _
"(ahmad>=feras)" & @CRLF & _
"" & @CRLF & _
"(feras<ahmad)" & @CRLF & _
"" & @CRLF & _
"(feras<=ahmad)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")