$re = '/(?:{|(?!^)\G)\s*\K(<[^>]+>|(?<PlaceholderValue>[^<>}]+)\b)/';
$str = 'Is this a { <strong> Versioned placeholder </strong> } file?
Is this a <strong> { Versioned placeholder } </strong> file?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);