re = /\b(?!\S*(?:fass|arbeit))\S*?a\S*\b/m
str = 'a
fa
fas
fass
sasafrass
afass
fassa
blarg
arbei
farbei
arbeit
farbeit
arbeits
farbeits
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end