#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?=(?:fass|arbeit)\b)(\S*?)a(\S*)\b"
Local $sString = "a" & @CRLF & _
"fa" & @CRLF & _
"fas" & @CRLF & _
"fass" & @CRLF & _
"sasafrass" & @CRLF & _
"afass" & @CRLF & _
"fassa" & @CRLF & _
"blarg" & @CRLF & _
"arbei" & @CRLF & _
"farbei" & @CRLF & _
"arbeit" & @CRLF & _
"farbeit" & @CRLF & _
"arbeits" & @CRLF & _
"farbeits" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")