package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[A-Za-z0-9_-~]+$`)
var str = `T|`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}