$re = '/\.([^\.]+)$/m';
$str = 'Rapport
Rapport.pdf
Rapport.123mdsxsdvsdv
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);