const regex = /(?:\+?\d+(?:\h+\d+)*,\h*)?(?:[^\s@]+@[^\s@,]+,\h*www\.\S+|\h*www\.\S+,\h*[^\s@]+@[^\s@,]+)|\+?\d+(?:\h+\d+)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\+?\\d+(?:\\h+\\d+)*,\\h*)?(?:[^\\s@]+@[^\\s@,]+,\\h*www\\.\\S+|\\h*www\\.\\S+,\\h*[^\\s@]+@[^\\s@,]+)|\\+?\\d+(?:\\h+\\d+)*', 'gm')
const str = `+35 00000000, info@company.com, www.company.com
+35 00000000, www.company.com, info@company.com
+35 00000000, +360000000, info@company.com, www.company.com
info@company.com, www.company.com
+35 00000000, info@company1.com, www.company1.com, +36 00000000, info@company2.com, www.company2.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}