#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?<=^(?!.*,))|(?<=, ))([A-Z]+)"
Local $sString = "JOSEPH W. JOHN" & @CRLF & _
"MIMI N. ALFORD" & @CRLF & _
"WANG E. Li" & @CRLF & _
"" & @CRLF & _
"AAMIR, DENNIS M" & @CRLF & _
"MAHAMMED, LINDA X" & @CRLF & _
"ABAD, FARLEY J"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")