re = /^(.+?)(.txt)$/m
str = 'C:/..../email_4.txt
C:/..../email_7.txt
C:/..../email_8.txt
C:/..../email_9.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end