$re = '/(?=.*\d)(?=.*[a-zA-Z])([a-zA-Z\d]{10})/m';
$str = 'sasas12212 211212jknn 211212jknnd 2121212122 csdcdcdcdc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);