$re = '#^
(?=[^A-Z\n]*[A-Z])
(?=[^a-z\n]*[a-z])
(?=[^\d\n]*\d)
(?=[^-+*/%\n]*[-+*/%])
(?=[^-~.?,:;\n]*[-~.?,:;])
.+
$#mx';
$str = 'test123T-
test123
sdsdsds
lorem ipsum';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);