#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*\d*[13579]\.article)|(.*[a-d|[f-m]$)"
Local $sString = "*** Match odds or A-M" & @CRLF & _
"(.*\d*[13579]\.article)|(.*[a-d|[f-m]$)" & @CRLF & _
"https://edu.rsc.org/science-research/salt-crystal-grows-legs/4012581.article" & @CRLF & _
"edu.rsc.org/45.article" & @CRLF & _
"edu.rsc.org/weuvkee/a" & @CRLF & _
"edu.rsc.org/weuvkee/f" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"****** Don't match" & @CRLF & _
"https://edu.rsc.org/ideas/5-ways-to-explain-titration/4012500.article?utm_source=house-list&utm_medium=email&utm_campaign=monthly-alert" & @CRLF & _
"https://edu.rsc.org/feature/making-materials-from-biomass/4012606.article" & @CRLF & _
"https://edu.rsc.org/eic/classroy" & @CRLF & _
"https://edu.rsc.org/wibble/chips/stuff/science" & @CRLF & _
"edu.rsc.org" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"*** Match evens or N-Z" & @CRLF & _
"(.*\d*[02468]\.article)|(.*[n-z]$)" & @CRLF & _
"https://edu.rsc.org/ideas/5-ways-to-explain-titration/4012500.article?utm_source=house-list&utm_medium=email&utm_campaign=monthly-alert" & @CRLF & _
"https://edu.rsc.org/feature/making-materials-from-biomass/4012606.article" & @CRLF & _
"https://edu.rsc.org/eic/classroy" & @CRLF & _
"https://edu.rsc.org/wibble/chips/stuff/science" & @CRLF & _
"" & @CRLF & _
"****** Don't match" & @CRLF & _
"https://edu.rsc.org/science-research/salt-crystal-grows-legs/4012581.article" & @CRLF & _
"edu.rsc.org/45.article" & @CRLF & _
"edu.rsc.org/weuvkee/a" & @CRLF & _
"edu.rsc.org/weuvkee/f"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")