package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\([0-9]+(\)|р\))`)
var str = `(500р)
(500)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}