re = /(?<![^,])""([A-Za-z].*?)""(?![^,])/m
str = '"Some Text","Some Text","18.3",""I Love You, Dad"","","","Some Text"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end