$re = '/(?<!\P{L})\d+/m';
$str = 'foo12 -> matches 12
foo 42 -> no match
foo.42 -> no match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);