$re = '/((^|^\d{2}-)\d{3,})-(\d+-)*(\d+)(?=-(ZE|KBR)-)/m';
$str = '437401-762-ZE-9-52-9.xml
02-419892-0-9743-KBR-2503-1-1.xml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);