import re
regex = re.compile(r"^([a-z, \(\)-]+?)?\(?([\d,]+)?\)?\s*?\(?([\d,-]+)?\)?$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("LOSS BEFORE INCOME TAXES (900,000) (900,000)\n"
"INCOME TAXES (RECOVERED) (90,000) (90,000)\n"
"RETAINED EARNINGS - BEGINNING OF YEAR 9,999,999 9,999,999\n"
"EXPENSES\n"
"Subcontracts 8,058 2,655\n"
"Business taxes 116 -\n"
"600,000 600,000\n"
"Salaries, wages and benefits 400,000 400,000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")