import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/(?:www\\.)?[-a-zA-Z0-9@:%._\\+~#=]{1,256}\\.[a-zA-Z0-9()]{1,6}(\\w)\\b(?:[-a-zA-Z0-9()@:%_\\+.~#?&\\/\\/=]*)";
final String string = "(\"https://www.fakesite.com test one\")\n"
+ "(\"https://www.fakesite.in test one\")\n"
+ "(\"https://www.fakesite.co.in test one\")\n"
+ "(\"https://www.fakesite.co.uk test one\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}