import re
regex = re.compile(r"((?:(us\-)?repository(?(1)|nocdn)?|h(?:(1)|(3)|(5)|(p))\-(?(6)webs01\-s|repo(?(3)(sitory)?01|(?(4)sitory02|(?(5)sitory03|)))\-v))|repo(?:nocdn|us)\.wip|(?:nocdn|us)\-repository\.gtm|91-228-167-25\.ptr)\.eset\.com", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("repository.eset.com\n"
"us-repository.eset.com\n"
"repositorynocdn.eset.com\n"
"hp-webs01-s.eset.com\n"
"h1-repo01-v.eset.com\n"
"h1-repository01-v.eset.com\n"
"h3-repository02-v.eset.com\n"
"h5-repository03-v.eset.com\n"
"91-228-167-25.ptr.eset.com\n"
"nocdn-repository.gtm.eset.com\n"
"us-repository.gtm.eset.com\n"
"reponocdn.wip.eset.com\n"
"reponocdn.wip.eset.com\n"
"reponocdn.wip.eset.com\n"
"repous.wip.eset.com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")