$re = '/\babc\b/m';
$str = '12%
ab
abc
abcc
abccc
ab abc
abcccc
abccccc
abcccccc
abcbcbcbc
abcd abc abcde
abcbcbcbcbcbc
abc
- _ { } @
3%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);