const regex = /\b(?!([C-Z][Y-Z]\d{7}[A-M]))([A-B][A-X]\d{7}[A-X]\b)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!([C-Z][Y-Z]\\d{7}[A-M]))([A-B][A-X]\\d{7}[A-X]\\b)', 'gi')
const str = `ab1234567m
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}