$re = '/^(?=\D*\d)(?=[^A-Z]*[A-Z])\S{8,15}$/m';
$str = 'aBcd1234
aB cd1234
abcd1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);