use strict;
my $str = '
======================================================================
TGS
======================================================================
Opening log at 1:58:03 PM on 4/29/2016
Parameters :
TargetFile:
GeneratedControlFile:False
Path and filename :
Try upload file :
Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\AppointLetters_2016_3_25_14_30.csv Complete, status : 226 Transfer complete.
Path and filename : D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\AppointLetters_2016_3_25_14_30.csv
Try upload file :
Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\AppointLetters_2016_3_26_14_30.csv Complete, status : 226 Transfer complete.
Path and filename : D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\AppointLetters_2016_3_26_14_30.csv
Try upload file :
Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\AppointLetters_2016_3_27_13_30.csv Complete, status : 226 Transfer complete.
Path and filename : D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_7_13_0.csv
Try upload file :
Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_8_13_0.csv Complete, status : 226 Transfer complete.
Path and filename : D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_8_13_0.csv
Try upload file :
Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_9_13_0.csv Complete, status : 226 Transfer complete.
Path and filename : D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_9_13_0.csv
Try upload file :
Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_9_13_0.csv Complete, status : 226 Transfer complete.
Closing log at 2:00:56 PM on 4/29/2016
';
my $regex = qr/Try[^\:]+\:\s(?<file>[^\v]+)?\vUpload\sFile\s(?<msg>[^\.]+\.[^\s]+\s[^\v]+)\v{2}Closing[^\d]+(?<time>[^(on)]+)on\s(?<date>[^\$]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}