package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[01]?[0-9][0-9]?$`)
var str = `0
99
100
199
200`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}