import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(department(s)? of |in\\n)(\\w+ ?\\w+[^,]?\\w+[^,]?\\w+[ ]?\\w+[ ]?\\w+)";
final String string = "Virginia Tech Sample:\n"
+ "A COMPARISON OF THE EFFICIENCY AND EFFECTIVENESS\n"
+ "OF TWO MODELS FOR DETERMINING THE COST\n"
+ "OF SPECIAL EDUCATION PROGRAMS\n"
+ "by\n"
+ "Kenneth L. Kienas\n"
+ "Dissertation submitted to the Faculty of the\n"
+ "Virginia Polytechnic Institute and State University\n"
+ "in partial fulfillment of the requirements for the degree of\n"
+ "DOCTOR OF EDUCATION\n"
+ "in\n"
+ "Administration and Supervision of Special Education\n"
+ "APPRQVED:\n"
+ "Richard G. Salmon, Co-Chairman Phili R. Jones, Co-Chairman\n"
+ "John A. McLaughlin Shirley A Jones\n"
+ "Shirley A. Underwood\n"
+ "May, 1986\n"
+ "Blacksburg, Virginia\n"
+ "--------------------------------------------------------\n"
+ "MIT Sample:\n"
+ "THE RESPONSE OF CONTINUOUS SYSTEMS\n"
+ "TO RANDOM NOISE FIELDS\n"
+ "by \n"
+ "Richard H. Lyon\n"
+ "A. B., Evansville College, 1952\n"
+ "Submitted in Partial Fulfillment of the\n"
+ "Requirements for the Degree of\n"
+ "Doctor of Philosophy\n"
+ "at the\n"
+ "MASSACHUSETTS INSTITUTE OF TECHNOLOGY\n"
+ "June, 1955\n"
+ "Signature of Author\n"
+ "department of Physics, May 16, 1955\n"
+ "Certified by\n"
+ "Thesis Supervisor\n"
+ "Accepted by\n"
+ "Chairman, Departmental Committee on Graduate, Students\n"
+ "---------------------------------------------------------\n"
+ "MIT Sample:\n"
+ "ON THE MECHANICS OF TWIST INSERTION\n"
+ "by\n"
+ "ALY H, M, EL-SHIEKH\n"
+ "B.Sc. University of Alexandria, U.A.R.\n"
+ "1956\n"
+ "S.M. Massachusetts Institute of Technology\n"
+ "1961\n"
+ "M.E. Massachusetts Institute of Technology\n"
+ "1964\n"
+ "Submitted in Partial Fulfillment\n"
+ "of the Requirements for the\n"
+ "Degree of Doctor of Science\n"
+ "at the\n"
+ "MASSACHUSETTS INSTITUTE OF TECHNOLOGY\n"
+ "May 1965\n"
+ "Signature of the Author\n"
+ "department of Mechanical Engineering\n"
+ "Fibers and Polymers Division\n"
+ "Certified by\n"
+ "Thesis Supervisor\n"
+ "Accepted by\n"
+ "Chairman Departmental Committee on Graduate Students\n"
+ "------------------------------------------------------------\n"
+ "MIT Sample:\n"
+ "HYDRAULIC DAMPER DESIGN\n"
+ "FOR A KNEE PROSTHESIS\n"
+ "by\n"
+ "Eric Hershler Bott\n"
+ "Submitted in Partial Fulfillment\n"
+ "of the Requirements for the\n"
+ "Degree of Bachelor of Science\n"
+ "at the\n"
+ "MASSACHUSETTS INSTITUTE OF TECHNOLOGY\n"
+ "February, 1975\n"
+ "Signature of Author\n"
+ "departments of Mechanical Engineering and\n"
+ "Physics, February 23, 1975\n"
+ "Certified by\n"
+ "Thesis Supervisor\n"
+ "Accepted by\n"
+ "Chairman, Departmental Committee on Theses\n"
+ "MAR 15 1976\n"
+ "LIBRARIES\n"
+ "------------------------------------------------------------\n"
+ "Virginia Tech Sample:\n"
+ "ASSESSMENT OF A MENTOR PROGRAM\n"
+ "ON SELF-CONCEPT AND ACHIEVEMENT VARIABLES\n"
+ "OF MIDDLE SCHOOL UNDERACHIEVERS\n"
+ "by\n"
+ "Helene Aiello\n"
+ "Dissertation submitted to the faculty of the Virginia\n"
+ "Polytechnic Institute and State University in partial\n"
+ "fulfillment of the requirements for the degree of\n"
+ "Doctor of Education\n"
+ "in\n"
+ "Administration and Supervision\n"
+ "Of\n"
+ "Special Education\n"
+ "APPROVED:\n"
+ "Philip R. Jones, Chairman Kenneth Underwood\n"
+ "Sylvia Auton\n"
+ "Shirley Jones Ronald McKeen\n"
+ "February 22, 1988\n"
+ "Blacksburg, Virginia";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}