const regex = /Try[^\:]+\:\s(?<file>[^\v]+)?\vUpload\sFile\s(?<msg>[^\.]+\.[^\s]+\s[^\v]+)\v{2}Closing[^\d]+(?<time>[^(on)]+)on\s(?<date>[^\$]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Try[^\\:]+\\:\\s(?<file>[^\\v]+)?\\vUpload\\sFile\\s(?<msg>[^\\.]+\\.[^\\s]+\\s[^\\v]+)\\v{2}Closing[^\\d]+(?<time>[^(on)]+)on\\s(?<date>[^\\$]+)', 'gm')
const str = `======================================================================
TGS
======================================================================
Opening log at 1:58:03 PM on 4/29/2016
Parameters :
TargetFile:
GeneratedControlFile:False
Path and filename :
Try upload file :
Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\AppointLetters_2016_3_25_14_30.csv Complete, status : 226 Transfer complete.
Path and filename : D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\AppointLetters_2016_3_25_14_30.csv
Try upload file :
Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\AppointLetters_2016_3_26_14_30.csv Complete, status : 226 Transfer complete.
Path and filename : D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\AppointLetters_2016_3_26_14_30.csv
Try upload file :
Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\AppointLetters_2016_3_27_13_30.csv Complete, status : 226 Transfer complete.
Path and filename : D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_7_13_0.csv
Try upload file :
Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_8_13_0.csv Complete, status : 226 Transfer complete.
Path and filename : D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_8_13_0.csv
Try upload file :
Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_9_13_0.csv Complete, status : 226 Transfer complete.
Path and filename : D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_9_13_0.csv
Try upload file :
Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrer\\BAAppointmentLetters_2016_4_9_13_0.csv Complete, status : 226 Transfer complete.
Closing log at 2:00:56 PM on 4/29/2016`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}