re = /(?<=")(.*)(?=")/m
str = '"https://gist.githubusercontent.com/anonymous/d2efee7b3967debc531d67de9cc7993a/raw/3f5e0e63ce6fe3aa4cffc2d0afafd2415408308a/gistfile1.txt"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end