$re = '/([A-Z])\1{2}(?!\1)([A-Z])\2{2}(?!\1|\2)([A-Z])\3{2}(?!\1|\2|\3)([A-Z])\4{2}/m';
$str = 'AAABBBCCCDDD
BBBAAADDDCCC
CCCAAABBBDDD
AAABBBAAABBB
AAAAAAAAAAAA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);