re = /\/(\d+)_.*$/
str = 'http://userimages-akm.imvu.com/catalog/includes/modules/phpbb2/images/avatars/145870556_47076915459092eafd7b69.jpg'
# Print the match result
str.match(re) do |match|
puts match.to_s
end