$re = '/user\s\'(?<User>[^\']+)\'\shas\s(?<Result>\w+)\sauthentication.*(count\sequals\s(?<Count>\d+))?/m';
$str = '2018-07-02 09:18:44,761 https-nsse-nio-8663-exec-90 anonymous 558x723020x25 5lqwk7 88.128.203.123,30.118.254.78 /best/madget/1.0/login The user \'JRA3620\' has FAILED authentication. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);